SpoofGuard User’s Guide:
SpoofGuard a tool to help everyday web surfers detect “spoofed” web sites.  Suppose one were to accidentally type “www.eday.com” into their browser as a URL or click on a link that directed them to “www.paypai.com” or a more subtle “http://popularsite.com@badguy.com”

The owners of eday, paypai and badguy have an opportunity to maintain the illusion that web surfers are browsing certain more trusted sites by making eday, paypai and badguy look like those more popular sites.  The owner of paypai.com, for example, can then gain access to particularly sensitive information if users mistakenly try to log in to paypai.  SpoofGuard is a tool to help users detect web site “spoofs” like these to reduce their vulnerability to such exploits.  

Installing SpoofGuard on Internet Explorer:
1.
Run the MSI installer from here
2.
Restart your browser

3.
Display the toolbar by right-clicking on a toolbar and selecting SpoofGuard or select View->Toolbars->SpoofGuard
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Select SpoofGuard to use SpoofGuard
Uninstalling SpoofGuard:

1. Go to Start Menu->Settings->Control Panel->Add/Remove Programs

2. Select SpoofGuard
3. Select Remove

Installing the DLL Yourself:

1. You can either use the precompiled dll or compile it yourself. Once you have the SpoofGuard.dll file, put it somewhere where it is unlikely to be moved. 

2. Register the dll in a command prompt using the regsvr32.exe application. (Select the 'Run' menu item from the Start Menu and type 'cmd'. At the command prompt navigate to where you have placed the dll and type "/WINNT/system32/regsvr32.exe SpoofGuard.dll." A dialog should confirm the registration.) 

3. Launch Internet Explorer and select "View->Toolbars->SpoofGuard Class" menu item. The SpoofGuard toolbar should appear among the other toolbars at the top of the IE Window. 

Un-Installing the DLL Yourself:

1. Deselect the URL Guard toolbar in IE. (Select the "View->Toolbars->SpoofGuard" menu item so that it is unchecked and the URL Guard toolbar disappears.) 

2. Unregister the SpoofGuard.dll with regsvr32.exe. (Same as when installing but type "/WINNT/system32/regsvr32.exe /u SpoofGuard.dll" at the command prompt.) 

3. Delete the SpoofGuard.dll file (if you want). 

Building the DLL Yourself:

1. All code is in C++ and uses both WTL classes and MFC.  A brief guide to the code is available here.
2. You will need a recent version of Microsoft's Platform SDK and the Microsoft WTL 3.1 classes. You will also need to set up Visual Studio or whatever compiler you are using to access these libraries and header files. You can get the installers for both of these by searching for them at http://msdn.microsoft.com/downloads. 

3. In Visual C++, choose your Build Target from the "Build->Set Active Configuration" menu item. Compile with min size. For unicode to compile, a lot of the string constants and such need to be wrapped with the unicode macros. (You can enable unicode by going to "Project->Settings->c/C++" and adding UNICODE and _UNICODE definitions to the Preprocessor definitions in the "General" tab.) 

4. You may also have to add the "wininet.lib" library to the project by choosing "Project->Settings->Link Tab->General Tab" and adding wininet.lib to "Object/Library Modules field. 

Finally select "Build SpoofGuard.dll" from the Build menu to build the SpoofGuard.dll

Using SpoofGuard: 
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SpoofGuard will display the warning status of the current page in the toolbar
There are three buttons.  The first, the Settings Button, brings up the Settings dialog.  The second, the Status Button, displays the current domain (in case it is otherwise obscured) and a brief representation of the status (as a green, yellow or red light) and brings up a status message when pressed.  The third, the Reset Button removes all data collected by SpoofGuard (image hashes and password hashes), but WILL NOT clear the user's Internet Explorer History.

Whenever the browser navigates to a new page, SpoofGuard will perform five checks in two rounds, which we can adjust from the Settings dialog.  You can set Weight for each of the five checks and a total threshold.  Each check returns a boolean result.  A new site is flagged if the sum of the weights of all of the activated checks, that is, the checks that notice a problem, is greater than or equal to the Total Alert Level selected.  If a site is flagged, a red light will be displayed next to the domain name in the toolbar when (and if) the new site is navigated to.  If you select, in the Settings dialog, to be stopped before visiting a suspicious site, a flagged site will trigger a pop-up window that will warn you either before or after the browser navigates to a new page, depending on whether the site can be flagged with only the first round of checks, which occurs before navigation.
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The Options Dialog
The first round of checks occurs before the browser attempts to navigate to a new page.  At this point, the only information available to the browser (and the SpoofGuard Toolbar) is the URL that it will attempt to navigate to.  The two checks done in the first round are the Domain Name check and URL check.  If the results of the Domain Name check and URL check are enough to flag a site, you will be warned before the page is loaded and be given the option not to navigate to the attempted page.
Domain Name Check: 

This compares the domain name of the attempted url to the domains in the most recent browser history entries.  If the attempted domain is similar to one such history entry, the Domain Name check is activated.  This is to call attention to possibly misleading links like http://www.paypaI.com (paypai with a capital i).  Similarity is determined by the Edit Distance between the two domains.  The Edit Distance is the number of characters that need to be inserted or deleted in order to transform one domain into another.  You can adjust the sensitivity of this check by adjusting the maximum edit distance such that the two domains would be considered similar.  You can also select how many history entries the Domain Name check will compare the current domain to.

URL Check: 

The URL Check will check the rest of the attempted URL for problems.  This will perform three different checks on the attempted URL.  First, it checks if there is a suspicious embedded username in the URL:  a suspicious embedded username would be one that contains “www.”, “.com” or any of a list of similar terms.  Second, it checks if the domain name looks obscured, which, similarly, would be a domain name that does not contain “www.”, “.com” or any of the same list of similar terms.  A careless user attempting to visit http://www.paypal.com@123.123.123.123 may think he’s visiting http://www.paypal.com.  Third, the URL check will check the attempted port number and will raise a problem if the attempted port is not a standard port (http, https, ftp, gopher, socks).  If any of the three checks suggests up a problem, the URL check will be activated.

Email Check:
Similarly, the Email Check will attempt to determine if the browser has been directed to the current URL by email.  It will check for either an empty referral field or one that indicates referral from a known web-based email site such as Hotmail.com or Mail.Yahoo.com.
If the three first round checks are sufficient to flag an attempted site, meaning the sum of the weights of the activated checks is greater than or equal to the Total Alert Level, you may be presented the option not to navigate to the attempted page.
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Pre-Navigation Warning
If a page is actually navigated to, the second round checks will be performed once the entire document has loaded.  At this point, the browser has access to all of the information represented on the document, including the body of the HTML and the images displayed.
Password Check: 

The Password Check searches the body of the document, which is parsed by the browser, and is activated when for input fields of type “password” are found.  This, in itself, does not suggest that a particular page is a spoof, but you may be more concerned about the other checks that SpoofGuard performs.  Effectively, this lowers the Total Alert Level for pages that contain password fields, which are, presumably, the pages that you are most concerned about.
Similarly, the Unencrypted Password Check triggers a flag if there is a password field on an unencrypted frame.
Link Check: 

The Link Check searches the body of the document for suspicious links.  A suspicious link is a link that references a suspicious URL.  A suspicious URL is one such that the sum of the weights of the activated first round checks, both of which work on only a URL, is greater than the Link Sensitivity.  This means that attempting to visit the URL will trigger a warning.

Image Check: 

The Image Check compares images on a new site to images on previous sites.  This is done by retrieving every image from the current page out of the cache (so that no extra traffic is created), hashing it and comparing it to previous hash values.  If performance is an issue, you can select not to hash new images.

After all the checks are done, the sum of the weights of all the activated checks from both the first and second round is computed and, if it’s greater than the Total Alert Level, a Post-Navigation Warning may be raised.  It will not come up if you select not to display pop-up warnings or if you have already been warned before navigating to the page.  Either way, you can click on the button that displays the domain name to display the status of the current site, that is, messages from all of the checks that were activated.
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Click on the Status Button (red here) to display the status of the Current Page
Password Tracking: 

If selected, the Password Tracking feature will interrupt the user before typing the same username and password into more than one site.  This is done by storing the hash of a user's username and password whenever something resembling a username and password is submitted to a web site.
Questions and Comments:
Contact the author at led242@stanford.edu
SpoofGuard Code Roadmap
This document is intended to help programmers with little or no experience with Windows or COM programming, who want to understand, extend or adjust the code behind SpoofGuard, an Internet Explorer plug-in to help web surfers detect web spoofs.  Since the source code is available, this document will focus on those aspects which are both critical to the understanding of how SpoofGuard works and likely to be changed in future implementations.  This document assumes that the reader has read the SpoofGuard user’s guide (included above) and is familiar with what SpoofGuard does.
Background:
SpoofGuard is written in C++ and interfaces with the Internet Explorer browser through Microsoft’s COM interface.  The compiled product is a DLL application extension.  The basic design of this project comes from an article at The Code Project which may be worth looking at: http://www.codeproject.com/atl/ietoolbartutorial.asp?target=motleyfool
Description of classes
WarnBar:
This is the primary class required to implement an Internet Explorer toolbar.  WarnBar is a COM component (the only COM component in SpoofGuard) that extends the IDeskBand interface, among others; this interfaces exposes the necessary methods.  WarnBar is where most of the interesting work is done, and will be discussed in further detail below, after the rest of the classes involved in SpoofGuard are discussed.

Two window classes must be implemented in order to define the appearance and user interaction of the bar.  Both implement the CWindowImpl interface to do this.  Upon initialization of WarnBar, a new instance of ReflectionWnd is created and registered, which creates a new instance of UWToolBar.
ReflectionWnd:
This window class implements a transparent window that sits on top of the toolbar and takes user messages (like mouse clicks) and reflects them to the UWToolbar, which defines the buttons that respond to these messages.  When this class is created by WarnBar, it creates and registers a new UWToolBar.  From WarnBar, accessing UWToolBar is done through this class.  ReflectionWnd is able to pass messages to its instance of UWToolBar by registering it in a message map constructed with macros defined in the Microsoft ATL:
BEGIN_MSG_MAP(CReflectionWnd)


MESSAGE_HANDLER(WM_CREATE, OnCreate);
/* registers the OnCrate method to fire

when ReflectionWnd is initialized*/

CHAIN_MSG_MAP_MEMBER(m_ToolBarWnd);

/* passes messages to UWToolBar instance */
END_MSG_MAP()

UWToolBar:
This window class defines the buttons and appearance of the toolbar.  It receives messages from the ReflectionWnd that created it:

BEGIN_MSG_MAP(CUWToolBar)



MESSAGE_HANDLER(WM_CREATE, OnCreate);



MESSAGE_HANDLER(WM_COMMAND, OnCommand);


END_MSG_MAP()

The first handler is the standard initialization method handler, as seen in ReflectionWnd.  This is triggered by ReflectionWnd when it attempts to create a new UWToolBar instance.  The second handler covers the commands that are expected to be passed through ReflectionWnd.  No other messages are expected or handled.
While the toolbar is running, UWToolBar also stores the state of the user settings.  That is, each of the fields that the user can adjust in the Settings Dialog (weights, sensitivity, Total Alert Value, etc) is represented by an instance variable in UWToolBar.  WarnBar, which uses this data, must access UWToolBar each time it wants to retrieve this data.  This is because the Settings Dialog is fired from UWToolBar, without notifying WarnBar.  It doesn’t make sense, then, to store the state in WarnBar.  Additionally, UWToolBar exports methods to set the current status of the page.  That is, other classes, particularly WarnBar, can change the icon and domain name on the Status Button as well as the message that appears on the Status Dialog.
Upon initialization of UWToolBar, two buttons are created and registered such that they fire IDM_OPTIONS and IDM_STATUSBUTTON events, which are meant to trigger the Settings and Domain Dialogs, respectively.  When a user clicks on one of these buttons, the message is received by ReflectionWnd (as a general WM_COMMAND) and is passed to UWToolBar, which fires OnCommand.  OnCommand interprets the command and, if the event is an IDM_OPTIONS or an IDM_STATUSBUTTON, the appropriate dialog is initialized and fired.  In the case where the Settings Dialog is fired, a new ConfigDlg is initialized with the current state of the user settings, and the UWToolBar updates the state based on the result that ConfigDlg returns when the dialog terminates.  Similarly, the Status Dialog is initialized with a string that represents the status of the current page, passed to UWToolBar from WarnBar whenever the browser navigates to a new page.
TestDlg:
This class exists only to handle the Settings Dialog.  TestDlg retains an instance variable for each field in the dialog window, such as the Total Alert Level.  When UWToolBar opens a new Settings Dialog, which occurs each time the Settings button is pressed, it creates a new instance of TestDlg and sets the initial state of the dialog box by initializing TestDlg’s instance variables.  While the Settings Dialog is running, TestDlg intercepts all the events it fires, like clicking on a radio button, and continually stores the state of the dialog.  It also updates the state of the Status Dialog whenever the state changes.  When the user terminates the dialog, UWToolBar extracts the values of the instance variables from ConfigDlg and saves them.  The dialog associated with this class is defined in the resource file URLWarning.rc:
IDD_CONFIGDLG DIALOG DISCARDABLE  0, 0, 520, 306

STYLE DS_MODALFRAME | WS_POPUP | WS_CAPTION

CAPTION "Settings"

FONT 8, "MS Sans Serif"

BEGIN

    DEFPUSHBUTTON   "OK",IDOK,393,282,50,14

    PUSHBUTTON      "Cancel",IDCANCEL,457,282,50,14

    RADIOBUTTON     "1",IDC_DISTANCE1,331,46,24,13,BS_LEFT

    RADIOBUTTON     "2",IDC_DISTANCE2,331,57,21,13,BS_LEFT

...

END

The elements listed in the dialog definition trigger the bolded event codes, which are defined in Resource.h:
#define IDC_DISTANCE1                   246

#define IDC_DISTANCE2                   247

Note that IDOK and IDCANCEL are standard event codes, which correspond to the “OK” and “Cancel” buttons on the dialog, and do not need to be defined in Resource.h.  Programmers using Visual Studio will probably find it simpler to use the built in Resource Viewer to edit URLWarning.rc and Resource.h indirectly rather than edit them manually.  Occasionally, a new event code defined in the Resource Viewer may create a collision in Resource.h, which can be corrected manually.  TestDlg handles these events by registering handlers, defined inside TestDlg, in a message map constructed with macros defined in the Microsoft ATL.
BEGIN_MSG_MAP(CConfigDlg)


MESSAGE_HANDLER(WM_INITDIALOG, OnInitDialog)


COMMAND_ID_HANDLER(IDOK, OnOK)


COMMAND_ID_HANDLER(IDCANCEL, OnCancel)


COMMAND_ID_HANDLER(IDC_DISTANCE1, OnDistance1)


COMMAND_ID_HANDLER(IDC_DISTANCE2, OnDistance2)

...
END_MSG_MAP()
Here, the OnDistance2 method is registered to handle the IDC_DISTANCE2 event code.  In this case, IDC_DISTANCE2 is the radio button associated with setting the sensitivity, represented as edit distance, of the Domain Check to 2.  This event code is fired whenever the user clicks on this radio button in the Settings Dialog.  OnDistance2 sets ConfigDlg’s corresponding instance variable, DISTANCE, “checks” the IDC_DISTANCE2 radio button and “unchecks” the rest of the radio buttons corresponding to the Domain Check sensitivity settings:
LRESULT OnDistance2(...) {

DISTANCE = 2;


CheckDlgButton(IDC_DISTANCE1, BST_UNCHECKED);


CheckDlgButton(IDC_DISTANCE2, BST_CHECKED);

...
}
DomainDlg:

This class exists only to handle the Status Dialog.  It is very similar to ConfigDlg, but much simpler.  This dialog only displays the warnings associated with the current page, so DomainDlg needs to interact with it only upon initialization to set the status message.
WarnBar:
With the previous classes in place, WarnBar can retrieve the current state of the user settings (weights, etc) and set the status of the current page.  When the toolbar is not running, the user settings are saved in the registry.  They are loaded in LoadRegVals() and saved in SaveRegVals() upon initialization and termination of the toolbar.  Additionally, WarnBar can make calls to its instance of ReflectionWnd to fire pop-up windows when necessary.  WarnBar also implements several COM interfaces using ATL macros.  Of these, most of WarnBar’s work is done in implementing only a couple interfaces:
BEGIN_COM_MAP(CWarnBar)


...

COM_INTERFACE_ENTRY(IObjectWithSite)


COM_INTERFACE_ENTRY_IID(IID_IDeskBand, IDeskBand)

...

END_COM_MAP()

IObjectWithSite:
The SetSite method in this implementation is used to initialize WarnBar and register the browser with it.  This method is called by the containing browser at the beginning of its execution and passes it a pointer to the containing object, the web browser.  This is a convenient place to put the initialization of WarnBar, which includes loading user settings from the registry, retrieving and saving the history list from the passed in browser, and passing the browser object to the ReflectionWnd and UWToolBar, which are also created here.  SetSite is also called immediately before the web browser terminates WarnBar, with a null value passed in.  In this case, this is used as a destructor, which deletes the history list and un-registers the UWToolBar.
DWebBrowserEvents2:
Additionally, the BeforeNavigate2 and DocumentComplete event handlers are added to this class in an event sink map:
BEGIN_SINK_MAP(CWarnBar) 
SINK_ENTRY_EX(0, (__uuidof(DWebBrowserEvents2)), DISPID_BEFORENAVIGATE2, BeforeNavigate2)

SINK_ENTRY_EX(0, (__uuidof(DWebBrowserEvents2)), DISPID_DOCUMENTCOMPLETE,DocumentComplete)

END_SINK_MAP()
BeforeNavigate2:
This event fires before navigation occurs in the given object (pDisp), which is either a window or frameset element.  This also gives WarnBar the URL that the browser is attempting to navigate to and allows WarnBar to cancel the browser’s navigation.  This is where WarnBar performs the first round checks, as these checks need only the URL of the attempted navigation.
BeforeNavigate2(Idispatch *pDisp,VARIANT *URL,...,VARIANT_BOOL *Cancel)

In the case where navigating object, given by pDisp, is not the outermost frame, or the browser, the first round checks are not done.  Rather, WarnBar only records whether the attempted URL is in the browser’s history so that, once navigation is complete, WarnBar can detect if there are any redirects (or frames) that are not in the browser’s history, a possible exploit.  WarnBar will not perform the first round checks if the domain of the attempted URL is already in the browser’s history.  In this case, the variable outerFrameIsInHistory is set to TRUE so that this page will also be ignored after navigation is complete.  Otherwise, the first round checks are done in the function FirstAlert, and a warning string is created to notify the user of any problems that the first round checks detected.  The three checks done here are Domain Check, URL Check and Email Check.  The Domain Check iterates through the history list initialized in SetSize and compares the current URL to each of them, using the Edit Distance as a metric.  The URL Check simply does a series of static checks on the structure that represents the parsed URL.  If the sum of the weights of the activated first round checks, that is, those that detect problems, is higher than the user’s Total Alert Level, then a pop-up warning message is fired, assuming the user selects this option, with the warning string that describes all the possible problems detected so far, where the user is given the option to cancel navigation.  If the user decides to do so, the value of Cancel, passed in by the browser, is set to TRUE to cancel navigation.  If the user decides to proceed anyway, or there are not enough detected problems to cancel navigation, the sum of the weights of all the activated checks is stored in an integer, preSum, and retrieved after navigation.
DocumentComplete:
This event fires when the given object (pDisp) has been completely loaded and initialized.  This means that every page, image and script of the document has loaded.  This is very similar to BeforeNavigate2, but there is no option to cancel navigation because navigation has already occurred when this has fired.  More interesting work can be done here since the content of the current page can be accessed, through the pDisp.
DocumentComplete(IDispatch* pDisp, VARIANT* URL)

This method also checks the current context to determine if it is working in the outermost frame, the web browser.  Otherwise, this method does nothing.  If the page is already in the user’s history, which is determined in BeforeNavigate2, this method does nothing except hash and store the images on the page, if the user selected to do so.  Otherwise, WarnBar performs the second round checks here.  These include the Image Check, Link Check and Password Check.  These three checks each retrieve the browser object from the given pDisp.  From this, they retrieve the current document.  Each check queries the document for a different set of information.  The Link Check simply retrieves a collection of all the links on the page and iterates through them.  It then performs the first round checks on each link, using FirstAlertClean, which does not write strings or attempt to write to global data, where the result of our original FirstAlert is stored.  If over a quarter of the links on the page (and at least one) come up as bad, or would give the user the option to cancel navigation if selected, this check is activated.  Similarly, the Password Check retrieves a collection of the forms on the current document.  For each form, it then retrieves a collection of all the form elements.  It then iterates through every form element and, if a “password” field is detected, is activated.  ImageCheck retrieves a collection of images from the current document.  This is a collection of image names, paths and size information.  If the image is within the range of appropriate sizes and dimensions, the image is retrieved from the browser’s cache.  Assuming this is successful, the image and current domain name are each hashed to a 20-byte value.  The image hash file is then opened and the current image and domain hashes are compared to each hash therein.  If an identical image hash is found with a different domain hash, the Image Check is activated.  Either way, the image and domain hashes are saved to the image hash file, which is kept at a constant size, defined as MAX_IMAGE_HASHES.  Once the checks are done, the weights of the activated checks are added to the sum of the weights of the first round checks, in preSum, to calculate the current alert, postSum, and the status message is updated, which is the concatenation of all the warning messages from all activated checks.  If current alert, postSum, is higher than the user’s Total Alert Level, the warning light in UWToolbar’s Status Button and, if the user hasn’t already been warned, will pop up the current status of the page as a warning message, through ReflectionWnd.
Adding a New Test:

All tests put their results into global arrays flags and warnings.  So, you’ll need to add an entry in the global flag and warning arrays for the new test.  You can do this by incrementing #define NUMBER_OF_TESTS and #define NUMBER_OF_WARNINGS and defining a new #define TEST_NEW, to represent the new test.  Flags is an array of ints (as booleans) that should be set when a test is triggered.  Warnings is an array of CStrings for their corresponding tests.
If you want the new test to possibly raise a warning, you’ll need to add a line to the function Total(), which is used to determine if the current site has passed the threshold, like the following:

if(flags[TEST_HTTPS]) total += m_ReflectionWnd.GetToolBar().GetXWeightValue();

In this case, the value to be added to the total alert level is taken from the toolbar (because it is editable by the user).  
If the test can be done with only the url of the page, then it should be used in the first check.  This can be added by putting your new function in FirstAlert.  If you want it to be used for the link check, you’ll also need to add a line to firstAlertClean, like the following:
if(URLCheck(urlComps, 0)) pre += m_ReflectionWnd.GetToolBar().GetUWeightValue();

make sure that you DO NOT alter any global data (flags, warnings) here.
Otherwise, put the test in SecondAlert (you may alter global data here, too).
If you want to let the user adjust the weight of this test, you’ll need to first add the control to TestDlg.  Add a variable to UWToolbar.h and a Setter and a Getter so you can adjust it from WarnBar.cpp.  Add another variable in TestDlg.h and an entry to the init dialog like:

SetDlgItemInt(IDC_EMAILCHECKWEIGHT,EMAILWeight);


SendDlgItemMessage(IDC_EMAILWEIGHTSPIN, UDM_SETRANGE, 0, MAKELONG(10, 1));
Then, in UWToolBar.cpp, add a setter and getter to the testDlg (like the rest).  Then, in RegisterAndCreateWindow, in WarnBar.cpp, add a line to load the saved results to the toolbar.  Also add an entry for each variable, in LoadRegVals, like:
            m_RegHist = data;

            res = RegQueryValueEx(hKey, _T("Dist"), NULL, &type, (BYTE*)(&data), &size);

            if(res == ERROR_SUCCESS)

            { ...

and in SaveRegVals:

        data = m_ReflectionWnd.GetToolBar().GetHistValue();

        res = RegSetValueEx(hKey, "Hist", 0, REG_DWORD, (BYTE*)(&data), size);

        if(res == ERROR_SUCCESS) { ...
Questions and Comments:
Contact the author at led242@stanford.edu
